Search This Blog

Tuesday, June 26, 2012

error: Failed dependencies: libc.so.6 is needed

I actually got this error while trying to install rpm of driver of a network card on RHEL 6.2 64 bit. That error looked something like this:

# rpm -i  myri_dbl-2.  1.0.51076-3636.x86_64.rpm
error: Failed dependencies:
        libc.so.6 is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libc.so.6(GLIBC_2.0) is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libc.so.6(GLIBC_2.1) is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libc.so.6(GLIBC_2.1.3) is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libc.so.6(GLIBC_2.3) is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libdl.so.2 is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libdl.so.2(GLIBC_2.0) is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libpthread.so.0 is needed by myri_dbl-2.1.0.51076-3636.x86_64
        libpthread.so.0(GLIBC_2.0) is needed by myri_dbl-2.1.0.51076-3636.x86_64


This error occurs because of some 32 dependencies which are required. The solution is to install 32 version of glibc.


# yum install libstdc++-4.4.6-4.el6.i686


This will mostly solve your problem.

6 comments:

Mahesh Chinni said...

Thank you very much. It solved my problem :-)

Anonymous said...

Thanks a ton.. It worked for me.. :)

Anonymous said...

It really works for me, Thanx!!

Anonymous said...

It really works for me, Thanx!

adarsh said...

I am trying to install a benchmarking tool called IOZONE and its the same error but its not working. Any suggestion would be appreciated.

Amazing Quotes said...

very amazing and interesting post, thank you for sharing
Great Quotes
Positive Life Quotes
Fitness Quotes - Best Quotes
Future Quotes - Success Quotes
Image Bank - Smile Quotes - Xyore
اقوال وحكم